LyX 2.4: from writing to typesetting
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1. Introduction

LyX 2.4 provides authors with all they need to write anything and then draws on the resources
of the TEX, XeTEX and LuaTgX typesetting engines to create superior documents for web and
print media. Originally created in the 1990s as a GUI for the ITEX macros which drive the
TEX typesetting engine written in Pascal by Donald Knuth (http://www-cs-staff.stanford.
edu/~uno/), LyX has been developed since 2009 to go beyond just letting people use KTEX to
giving authors all they need in one place.

1.1. A brief history of LyX

In 1995 Matthias Ettrich, one of the founders of KDE, created for INTEX a GUI initially called
Lyrix but later abbreviated to Iy X as a result of a copyright claim. In the early part of this
century development appeared to have faltered until decisions were taken to port LyX to Qt4,
thereby making it platform agnostic. It currently uses Qt5.

LyX has always implemented a useful subset of the IXTEX macros, including the most widely
used mathematical functions. LyX 2.0.0, released in 2011, added support for the XeTeX and
LuaTeX engines (the former originally developed by Jonathan Kew in 2004 and the latter
by a group of programmers in 2007, both to facilitate Unicode support) and for a range of
writing tools. Iy X 2.2.0, released in 2015, brought improved handling of tables and boxes and
a sophisticated advanced search.

The auto-save function in IyX is by far the best I have ever encountered and its emergency save
function as it senses a window crashing usually saves every last change that has been made. So,
as soon as I open a new file, I Save As to the folder where I intend to store it and its associated
files; thereafter I normally only save Ly X documents at the end of a session.

1.2. What LyX does

Iy X does not let you edit INTEX code; rather it makes a note of your requirements and, when
you ask to see what your masterpiece is going to look like, it sends a IATEX script to the relevant
TEX engine which produces the output for you.

It uses the same principle for lots of other things; for example, if you want to insert an image,
it calls on ImageMagick to convert the image format silently to PNG for display on your screen
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Figure 1: Paragraph styles for this document

and to EPS for passing to TEX. If you want to spellcheck your document, it uses the LibreOffice
dictionaries. By leaving other programs to do the heavy lifting, Iy’X can concentrate on making
life as easy for you as possible.

2. Writing aids from BTEX

Every IWTEX document belongs to a document class which supports a number of paragraph
styles; from a single book, article, report and letter class, there are now classes for other types of
documents, classes for different languages and classes for different organisations. For example,
the American Mathematical Society (AMS) made a major contribution early on by developing
a number of document classes for mathematical publishing.

So, having selected a document class, an author only has to pick a paragraph style from the
dropdown (Figure 1) to format anything they write. This saves a huge amount of time deciding
on formatting options and ensures that formats are consistent across the document; you do not
have to remember how you formatted a sub-section anywhere else in the document.

IATEX respects the punctuation conventions of the language which you select for the document;
so, even if you use English conventions, IXTEX will adjust those to the selected language.

IATEX considers the whole document when deciding where to make page breaks and considers
the whole paragraph when deciding where to hyphenate so that the breaks and hyphens give



the most pleasing appearance to the eye — but you can overrule INXTEX if you think you can
improve on its decisions.

In addition to numbered and bulleted lists, IATEX offers a description list in which, where you
might expect a number or a bullet point, the first word is highlighted in bold.

If you want to add a Contents list, W TEX will generate it from the chapter and section headings
you have used in the document and it will use the same chapter and section headings to generate
a contents list in a PDF.

If you put an image or a table in a float, as I did with figure 1, IATEX will insert it at the most
suitable position, normally at the top of the next page. If you want to insert a list of illustrations
or tables, it will use the captions in these floats to generate lists of these illustrations or tables.

You can rotate the image or table in a float; this will only show in the output — so you can
edit it in its upright position rather than having to do it at an angle.

You can have a long table which spans one or more page boundaries and ITEX will adjust the
page breaks in the table to match any changes in the page boundaries in the document.

You can insert a variety of boxes and manipulate the contents of the boxes.

If you label something, you can refer to or cross-reference it from anywhere else in the document.
You do not need to know which page it is on; INTEX will insert that for you.

Similarly, if you add an index label to anything, IATEX will generate an index based on those
index labels. In fact it can generate multiple indexes if you need them.

If you use either of the bibliographic database programs, BIBTEX or BIBXTEX, you can insert
citations and create a bibliography automatically. I¥TEX will keep track of them; you do not
need to worry whether your bibliography matches your citations — it will!

3. Writing aids from LyX

The LyX interface gives you a space in which to write your masterpiece plus the options to see
the Outliner and the I¥TEX code which will eventually form the script which IyX will send to
the relevant TEX engine.

In order to increase the number of available IXTEX features without overburdening the interface,
IyX packages a number as modules which you can add to your document without knowing
anything about INTEX. They range from simple typesetting features like drop capitals or custom
headers and footers to mathematical constructs and box manipulation features (see Figure 2).
When you add a module you may see some new paragraph styles or new options in, for example,
the Insert tab.

If you find that a module is not available, click on it and you will get a list of the I¥TEX packages
on which it relies; install these on your system and click on Tools> Reconfigure and LyX will
find them and make them available.

You can also do split screen editing, working on different parts of the same document, for
example, to ensure that you are not repeating yourself or that what you have said at one point
is consistent with what you have said elsewhere, or working on two different documents side
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by side, for example, when copy-editing something which will eventually be published in two
different languages.

Among the writing aids you are less likely to find elsewhere are:

e Advanced find: allowing you to find and replace a formatted word or expression, for
example, a word only when it is in italics or a mathematical expression.

o Continuous updating and navigation: the outliner and the navigation tab are instantly
updated to reflect the current state of the document making it easy to navigate anywhere
in the document at any time.

o Editing via the outliner: parts, chapters and sections can be promoted, demoted and
moved around in the outliner; any numbering is immediately updated to reflect the
change.

e Version control, allowing a disparate team to work on the same document stored in a
version control system.
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4. Writing and editing a document in LyX

Iy X comes with toolbars containing all the normal things a writer is likely to need along with
some specific to LyX (Figure 3).! The icons you are less likely to find elsewhere are:

e Advanced find: allowing you to find and replace a formatted word or expression, for
example, a word only when it is in italics or a mathematical expression.

o Navigate back: takes you back in the document to where you were before your last move.
e View: generates a PDF of the document as it will appear so far.

o Update: updates the PDF you have already generated to show changes that have been
made.

e Paragraph: reverts to the default paragraph style, for example, when you get to the end
of a list.

o Labelled list: creates a list where, instead of a bullet, the first word or phrase is followed
by an indented comment, definition, etc.

e Description: puts the first word in bold to introduce, for example, a definition or comment
on the word which is indented if it runs onto a second line.

e Section: starts a new section.

You won’t find an icon for bold because bold only became fashionable in the 1980s when
computer printers could not output italics; you use italics for Emphasis but you can apply bold,
strikethrough and lots of other options by clicking on the font icon.

4.1. Document class

There are documents classes for articles, books, CVs, letters, presentations, reports and scripts,
among others, and some of these, like KOMA-Script, come as bundles or collections of classes all
of which share the same features. The default document class when you open a new document
in LyX is Article (Standard Class) but I normally go to Document>Settings and change the

!There are other icon sets if you do not like the one in Figure 3.



Document class to KOMA-Script Article. KOMA-Script classes come with a wide range of
enhancements which are usually worth having.

Font size in IMTEX is determined by the font used for the body text, or standard paragraph
style. This is usually 10 or 11pt but can be changed normally to 12pt and in some classes to a
much wider range of font sizes. All other paragraph style font sizes in a particular document
class are set relative to this font size. If you wish to use system fonts rather than the KTEX
fonts supported directly by LyX, go to Document > Settings> Fonts and enable Use non-TEX
fonts; then select the appropriate Roman, Sanserif and Typewriter fonts.

Note that the fonts you use in the IATEX output are not the same as the fonts you will see on
screen which are set in Tools> Preferences>Look & Feel>Screen Fonts.

4.2. Paragraph styles

Everything within a document has a paragraph style; though figures, tables and mathematical
expressions can appear within a paragraph, they can also appear, as they should, within a float
in a standard paragraph of their own, and you have to click on = or select Edit>Paragraph
Settings in order to Center them. Note that a figure or table float must be inserted in a standard
paragraph; inserting it inadvertently in another paragraph style can cause unexpected results.

A small number of paragraph styles, for example, standard, quote and verse, only appear in the
main text; others like title, author, dedication and abstract are intended to appear at the start
of the document. The main groups which most users will use are the headings and the lists.

4.2.1. The headings

The chapter and section headings that you select will appear under Navigate and with View>
Outline Pane selected (as will the captions of any figures and tables and lists of the citations,
equations, footnotes, labels and margin notes you have used) allowing you to navigate easily to
any part of the document.

The headings form a hierarchy — Part, Chapter (books and reports only), Section, Subsection,
Subsubsection, Paragraph and Subparagraph; if you want to reorder whole chapters or sections
or promote or demote them within the hierarchy, select View> Outline Pane.

However, all the headings have an asterisked counterpart which omits the number and never
appears in a table of contents (Figure 1). Use these for unnumbered headings or where you are
not going to use a table of contents.

Exceptionally the KOMA-script document classes offer Addchap and Addsec paragraph styles
which are unnumbered but will appear in a table of contents.

The Paragraph and Subparagraph styles normally appear embedded in the following paragraph
in the output, though not on the input screen, for example:

The Paragraph style By default the paragraph styles called Paragraph and Subparagraph are
not numbered and do not appear in the table of contents but you can change these options in
Document > Settings > Numbering & TOC.
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Figure 4: Enumerate and Description

If you have appendices, go to the start of the first appendix and select Document Start
Appendix here; all the subsequent chapter or section headings will use alphabetical characters
for ‘numbering’ but otherwise the hierarchy will be preserved.

4.2.2. The lists

LyX offers four types of list, three of which — Itemize, Enumerate and Description — are
found in ITEX and Labelling which is only found in certain ITEX document classes but is
implemented by LyX through the addition of KTEX macros to those document classes that do
not have it as standard.

I have already used Itemize (bullets) in this document; so figure 4 illustrates Enumerate and
Description from a glossary of mathematical terms which I compiled during one of my courses.

With the Description style, the first word of the paragraph appears in bold and the remainder
in normal type; in order to get all the words ‘separation of variables’ and ‘simple harmonic
motion’ to appear as part of the expression to be defined, I used Insert>Formatting > Normal
space (Ctl-Alt-space) between each word.

Here the Enumerate (numbered) style is nested in the Description style and a long red square
bracket appears to the left of the paragraphs. With every level of nesting, another long red
square bracket is added so that you do not lose track of nesting levels.

This illustration also demonstrates the use of a label with the Description ‘simple harmonic
motion,’ cross-references to various other labels, specifying that the page on which the label
appears should be cited, mathematical expressions contained inline and a float which is closed



so that LyX does not have to load the contents of the float as you scroll through the document.

With Itemize and Enumerate the bullet or numbering style changes with each new nesting level;
for example,

1. I can start with a numbered paragraph and add
e a nested bulleted paragraph after which I can add another
— nested bulleted paragraph
a) or even start a nested numbered sequence.

This is a nested standard paragraph to illustrate how you can insert comments
or explanations between elements in a list and still

b) continue with the numbered sequence.

Note also how in the output IATEX lines up the nested standard paragraph with
the numbered paragraph and narrows the space between the lines to emphasise
their connection. All this is done automatically.

2. If I then return to the top level, the space between paragraphs increases and the numbering
carries on; but if I add

o a bulleted (or any other) paragraph at the same nesting level and then try
1. a numbered paragraph at the same nesting level, it restarts the numbering.

Though the nesting icons look like the indenting icons in other software, they do a significantly
different job and the paragraph style interacts with the nesting level to influence the horizontal
and vertical spacing of the text. Nestable paragraph styles normally only have four nesting
levels but they can be combined to create up to six nesting levels if required.

The Labelling style can be used as an alternative to Description but is particularly useful with
timelines such as these extracts taken from http://www.linux.org/info/
linux_timeline.html in 2009:

1992

February What could be described as the first Linux “distribution”, called MCC Interim
Linux is released by the University of Manchester, England.

January  alt.os.linux newsgroup created.

Minix creator Andrew Tannenbaum claims “Linux is obsolete” in a posting to
comp.os.minix and starts a public discussion on the merits of Linux in which Linus
Torvalds participates.

1991
December Robert Blum posts the first Linux FAQ

September Version 0.01 of Torvald’s project is made available via ftp.funet.fi. Ari Lemmke,
the systems administrator, gives the directory the name Linuz.



August Linus Torvalds announces that he’s working on an operating system similar to
Minix.

Note how the nested standard paragraph used for the entry starting ‘Minix’ lines up with the

Labelling paragraph style being used.

Note also that not all paragraph styles are nestable; if a style is not nestable, nothing you can
do will make it nestable.

To change the paragraph style of a single paragraph, select the desired paragraph style when
the cursor is somewhere in the paragraph. Otherwise, use highlighting across all the desired
paragraphs. When pasting a passage containing multiple paragraph styles, the first paragraph
style will take the paragraph style of the insertion point; so you may wish to change the
paragraph style of the insertion point to that of the first paragraph style in the passage before
pasting.

4.3. Getting the right —, ‘ and space

Typesetters, and therefore TEX, distinguish between what most people think of as a dash or
hyphen; so one of the few quirks of the Iy X interface that a new user needs to know is the
difference between a hyphen, an en dash, an em dash and a minus sign. The first three are
made with one, two or three ‘-’ characters and the fourth by using math mode.

Name | Unicode | Output | Made with | Used for
hyphen | U+2010 - - Word and line breaks
en dash | U+2013 - - From A-Z; pages 3-15
em dash | U4+2014 — - Dash — there it goes again!
minus sign | U42212 — Ctl-m -7 | 22 —y? =22

Because TEX was originally developed for 7-bit ASCII systems, it uses the backquote (") for
the opening quotation mark and the apostrophe (') for the closing quotation mark. LyX will
generally respect quotation marks in utf-8 but, if you import text from word-processors that
use different encodings, you may have to replace them to get the correct character to appear.

Less obviously, WTEX distinguishes between a full stop after an abbreviation and a full stop at
the end of a sentence and puts more space at the end of a sentence. However, this algorithm
is not perfect as IXTEX may think a full stop after a lower case character is at the end of a
sentence and one after an upper case character is after an abbreviation. So ‘It is I. No it is he’
and ‘Prof. Jones’ may be wrongly typeset. To adjust this insert an end of sentence full stop
(Ctl-full stop or Insertt>Special character> End of sentence) after ‘I' and an inter-word space after
‘Prof. (Ctl-Alt-space or Insert> Formatting > Normal Space). This produces ‘It is I. No it is he’
and ‘Prof. Jones. In my experience, this is less frequently a problem than not using the correct
dash.

4.4. Graphics, tables, floats and cross-references

Though tables and graphics are normally placed in floats and complicated mathematical
expressions in what is called display format, small tables and graphics and simple mathematical
expressions can be placed in-line. So, for example, you can include a mathematical formula
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You can insert a graphic or table directly into a document by selecting the icons in the top
row; selecting the ® icon on the top row or Insert> Graphics gives you the graphics window
(Figure 5). Selecting the B icon on the top row allows you to select the number of rows and
columns graphically; if you select Insert>Table, you get the standard window asking you to
specify the number of rows and columns.

You can also use a borderless table as an alternative to tab stops (which are never used by
typesetters) if you wish to lay something out in columns but without the overhead of a table
layout as I have done on page 24.

But, in most cases, it is better to place a graphic or a table in a float by selecting the ® icon
or Insert>Float> Figure or the @ or Insert> Float> Table on the second row. Each offers you a
placeholder for the caption and you can then insert the figure above or the table below the
caption within the float. If you find the graphic or table is left-justified, place the cursor to one
side of it and select the = icon or Edit>Paragraph Settings to change it.

Placing tables and graphics in floats has a number of advantages:

e wherever you insert the float in your document, TEX will place it in the most advantageous
position in the final document

e you can give it a label and cross-reference it so that you can refer back to it from anywhere
else in the document without needing to know its full title or page number

10



o TEX will number it correctly (and also correctly cross-reference it elsewhere in the
document) however many other floats, chapters or sections you have added since you first
inserted it

e you can close the float once you are satisfied with it, so that you don’t waste time
redrawing complicated tables or graphics on the screen every time you scroll through the
document.

You can scale or rotate a graphic or table. The scaling and rotation options in Figure 5 do not
affect the input screen of tables, only the output. So, for example, you can rotate a float table
in the output but continue to work on it in normal orientation in the input screen. Scaling
for the output screen has to be done manually; I normally view the initial result in a viewer,
put in a likely figure if it is too big and update the viewer to see if I need to make a further
adjustment. To change the input screen display size of a graphic select LaTeX and LyX options.

You can label almost anything in LyX by selecting Insert>Label or clicking on the label icon
when the cursor is at the start of a paragraph but it is sensible to restrict yourself to things
like chapters, sections, captions for figures or tables and items in a Description paragraph style.
This inserts a link in the file which you can cross-reference from anywhere else in the file.

Figure 6 shows this process once it was complete. 1 had entered the words ‘The graphics
window’ in the caption holder within the float and then placed the cursor at the start of the
caption before selecting the label icon. To help you remember each link, IiyX offers you a
human-readable description of the link, in this case fig: The-graphics-window, which helpfully
includes a prefix in case, for example, a section and a figure have the same title. You can edit
this or change it later if, for example, you decide to revise the wording of a section title but
note the lack of spaces if you do decide to change it. The human-readable description is for
your benefit; LyX doesn’t use it.

After I had accepted this label, I could select Insert>Cross-Reference or the book icon and then
select this link from the list of existing labels and enter it after ‘Figure . A greyed out box
Ref: fig:The-graphics-window tells me that I have inserted a cross-reference here. The default
cross-reference is to its number; so, when IATEX has worked out what the correct number for
this figure is going to be in the final document, it will insert the correct number in place of
the cross-reference. But there are other cross-referencing options; for example, you can get it
to refer to something ‘on page n’ as I did on the previous page which happens to appear in
figure 6; the greyed out box TextPage: sub:Accents is a cross-reference to the borderless table
on page 24. In fact, this option is even more intelligent; if ‘page n’ happens to be the same,
previous or next page, it says ‘on this/the previous/the following page’ or if ‘page n’ happens
to be the facing page of a two-sided document, it says ‘on the facing page.’

Being able to insert tables, figures, references and so on and then to refer to them from anywhere
else in the document without needing to know what number they will have or where they will
be in the final document while being absolutely sure that every cross-reference will be correct
is a huge time-saver for any author or editor.

As graphics are always inserted as a link, it is easy to update a graphic without even opening
IyX. Next time the document is previewed or printed, the new version of the graphic is used
and, as long as you have not changed the dimensions of the graphic, all will be well. However,
tables are another matter.

11
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Figure 6: Labelling and cross-referencing

You can import tables in CSV format with File>Import>Table (CSV) which creates a new file
with the table in it; you can then paste that table into your document, preferably within a float.
But there is currently no way of linking a LyX table with an external table; so, if you change
an external table, you have to re-import it into your LyX document.

Filling and adjusting tables within Iy X is extremely simple. When you create a table, its
columns are all narrow; as you make your entries, LyX adjusts the column widths to suit the
entries; if the table becomes too wide for the document, you select Edit> Table Settings from
within a column whose width you want to limit; you will be offered three options for adjusting
the Width: Text length, Variable and Custom. If you choose Custom you can set an absolute
value for Width. Depending on what you want to achieve, you can allow LyX to work out the
widths of the rest of the columns or you can repeat the process with other columns until you
get what you want — in many cases much quicker than laboriously altering every column as
you often have to do in other programs.

There are both drop-down menus and a context sensitive toolbar to help you adjust tables; this
enables a wide range of adjustments to be made to a table and to individual cells. There is no
horizontal scroll in LyX; instead there is a series of buttons to the right of the buttons in the

context sensitive toolbar to add and delete rows and columns E M % % S # & ¥ 4]lowing you
move the cursor around a table.

IXTEX will normally put a float at the top of the next page unless it is more than half a page
long, in which case it will normally be given its own page but, while the cursor is within the
float, you can change these defaults in Edit> Float Settings. Where a table is likely to extend
over two pages, you can insert a table in an empty paragraph and then select Edit>Table
Settings > Multi-Page Tabler> Use Multi-Page Table instead of using a float; you can then decide

12



how the headings will be handled after the page break. Though you can specify a break point,
you don’t have to worry about that unless you have very specific requirements; every time you
revise the document, all will be taken care of.

4.5. Tables of contents, lists and an index

A book normally has a table of contents and may have lists of tables or figures, a bibliography
and an index — and you may wish to include one or more of these in an article or a report. All
these and more are available under Insert> List/ TOC. The lists will draw on the headings and
captions you have inserted in the document and are updated instantly if you add, or change
the name of, a chapter, section, table or figure — another huge time saver compared with most
other programs.

A bibliography may be added by using the Bibliography paragraph style but most users will
benefit from using BIBTEX or BIBXTEX (Section 7). Creating an index relies on selecting
Insert>Lists/ TOC> Index List in an empty standard paragraph where you want the index to
appear in the document and then selecting Insert>Index Entry or clicking on the tabbed folder
icon when the cursor is at the end of each word or phrase you want to be in the index. Here
the content of the index label is important. IxX offers you the preceding word as the index
entry and you can change that to the preceding phrase or a different phrase.

For example, in a book I edited I wanted ‘drug users’ to appear in the index; so, each time
I indexed a passage in which drug use was mentioned, I inserted the index label ‘drug users’
even through the words in the text might be ‘drug abuse’ or ‘drug user.” If the index label is
different, A TEX gives each a different entry in the index. If they are the same, all the page
references are collected under the one index entry. Of course, the index is only any use if you
are going to use one of the TEX engines to generate the final document as it refers back to the
pages output by the TEX engine. But because it is actually done at the time of previewing or
printing, even if you change the page size or margins at the last minute, you can be sure that
every page reference is still correct in the index. You can also generate multiple indexes in IyX
by going to Document > Settings > Indexes.

If you want to know more about good quality indexing or indeed anything about book publishing,
it is worth getting hold of Butcher’s copy-editing (Butcher et al., 2006), the UK equivalent of
the Chicago manual.

4.6. The Preamble and TEX code

Because it will be impossible for a GUI to support every IIEX package, LyX has always had
the facility to insert TEX code into a document. To insert code that needs to go in the TEX
preamble, that is, before the start of the document, select Document > Settings > IKTEX Preamble
and add the relevant code. To insert code within a document use Ctl-1 , select Insert>TeX Code
or click on the TEX icon.

With so many modules now available, you are unlikely to need to add TEX code, unless you are
writing a book. Typesetters distinguish the front matter of a book from the main matter and,
for example, use Roman numerals for the page numbers in the front matter. Iy’X does not yet
handle this natively; so you need to insert the ITEX macros \frontmatter and \mainmatter
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Figure 7: The LyX interface

at the start of the book before the title and before the start of chapter 1 respectively (see Filer
Open Example>Books> KOMA-Script Book). You also need to use the Chapter paragraph style
for the Foreword, Preface, Acknowledgements etc. in the front matter even though these are
not numbered in a book. They will then be printed correctly in the table of contents and in
any PDF output but LyX does not yet take account of this and numbers them as chapters,
throwing all the other chapter numbers out.

It is advisable not to enter I¥IEX code for anything which IyX supports as you may duplicate
code or use a macro which conflicts with the way [y X implements KTEX macros.

4.7. The LyX interface

As shown in figure 7, you can View the Outline Pane to the left of the split screen with two
documents side by side, View the Code Preview Pane, showing the script which LyX will send
to WTEX, at the bottom and, in the bottom right hand corner, see the slider for resizing the
screen.

At the bottom of the Outline Pane, you can see the arrows allowing you to promote or demote
a section, for example, from section to chapter or section to subsection or to move the content
of a particular part, chapter or section earlier or later in the document.

I normally only open the Outline or Code Preview Pane when I need them but frequently use
split screen editing, particularly on long documents, to ensure that what I have written in one
place is consistent with what I have written in another.

Alternatively, you can View the Messages Pane at the bottom of the screen where the Code
Preview Pane can be seen in Figure 7. Error messages will appear here; so open this pane if
things do not appear to be going to plan.
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5. Print and web media

TEX was originally designed for print media and over the last decade printers have moved over
to using PDFs as the source for printed material and LyX has long supported PDF output.

To take full advantage of all the features in a PDF, go to Document > Settings>PDF properties
and tick Use Hyperref Support. In the Hyperlinks tab (Figure 8), you will find options to change
the default settings; I normally tick all three. That will give you the standard colours for
PDF links. It you want to use different colours, select Additional Options and enter the colours
you want to use in Hypersetup (Figure 9). In this case, I have changed all the links other
those containing URLs to black. To keep these changes, you can Save as Document Defaults in
Document > Settings> Document Class (unless you intend to use a different class more frequently).

If you select the two-sided setting in Document> Settings > Page Layout when using a book or
report document class you may find a lot of blank pages in your viewer as ITgX automatically
starts chapters on the right hand page. The advantages are that the page numbers now appear
on the outside of the page rather than in the centre and you can be creative with your running
headers.

LyX 2.4 will also export to DocBook 5 and ePub and will generate an HTML file using XHTMLS5.

6. The maths editor

ILyX supported many of the INTEX maths macros from the outset but the maths editor has
changed more than most other parts of the interface as successive developers have tried to
wrestle with the huge number of mathematical symbols needed — most alphabets don’t have
more than 40 characters and so editing text is relatively simple by comparison.

There are really three levels at which you can use the IyX maths editor with any document
class — with a small number of keyboard combinations, with the basic maths toolbar and with
the advanced maths toolbar. You can also insert IATEX maths macros into a document and you
can use an AMS document class.

6.1. Very basic maths

You can enter mathematics in-line with Ctl-m or in display mode, normally used in a separate
paragraph, with Ctl-M (Ctl-shift-m). But you can also use math mode to set out text in certain
contexts; for example, you might want to say that:

Speed — DisFance

Time
Here I began with Ctl-M to obtain display mode and then entered Ctl-m (which also allows
you to enter text as text within maths mode) to enter ‘Speed.” This text was nested in math
mode; so I had to move the cursor out of the nested text back into math mode to enter the
equals sign and then the fraction (% in the basic maths toolbar). The fraction appeared with
two empty containers. I put the cursor in each of these and entered Ctl-m each time in order

to add the text above and below the line. I then moved the cursor out of all the containers and
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pressed Enter in order to start the next paragraph. Had I not entered Ctl-m in math mode in
order to use text mode nested within math mode, I would have got Speed because TEX would
have assumed I was entering a mathematical expression.

The point of using math mode in a situation like this is that the result is perfectly typeset in a
way which, if not impossible, is more difficult to achieve in a word-processor. However, most
people will want to use math mode for more formal mathematics.

Apart from Ctr-m or Ctl-M to initiate math mode, it is worth knowing ~ to add superscripts
like powers and _ to add subscripts. You can enter things like 22 — y> = 2?2 without ever
using the toolbar. Note that the output has spaces in the expression which are generated by
KTEX; only in a limited number of situations is it necessary to add extra spaces when entering
expressions in math mode.

Whenever you use these keyboard combinations, you are creating a nested container in which
to place one or more expressions. When a container is empty, it has a blue border; when
you fill it, the border disappears and is often replaced by red markers at each corner. These
markers can be a little indistinct on the screen but they are useful when, for exampltla, you
place a container within another container. For example, to enter an expression like z2, you
follow x with a superscript container and then the two fraction containers. Having added the 1
and 2 to the fraction containers, you move out of the fraction containers first, then out of the
superscript container and finally out of the math mode container. As you move the cursor, you
will normally see it cross the boundaries of the containers as marked by the red corners.

You can move out of a container by using Esc or the arrow keys or the space bar if you are
at the end of the expression in the container. Using the space bar elsewhere can produce
unexpected results; so I generally avoid this method though IXNTEX users who are used to ending
an expression with a space will find it natural.

6.2. The basic toolbar

Whenever you enter math mode, one or both maths toolbars appear; if both appear, the 7 icon
on the right allows you to toggle just the basic toolbar or both of them. The first three icons
toggle in-line and display mode and allow you to enter subscripts and superscripts; the square
root icon has a single container and the root icon has two. Next comes the simple fraction icon.
The following examples from a mathematical textbook (Courant and Robbins, 1996) illustrate
how IXTEX can sympathetically typeset deeply nested expressions using the simple root and

fraction functions:
om \/2—\/2+\/2+...+\/§

% can be expressed as:
1+ =1+ g =1+t =1+ =1+ — =14+ — =1+ —
611 220 2+ 33 2+ o3y 2 2T S —
153 153 % 2+7L6

> illustrates the difference between in-line and display mode; if I enter ) ;" ; in-line, the sub-
and superscripts appear after the > whereas the same expression in display mode
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i=1

shows the sub- and superscripts in the correct positions (as also happens with the product ]
and co-product [J).

The next four icons offer you the three commonest delimiters and access to the full range of
available delimiters including omitting one of a pair (as I did after [[, having used an ordinary
‘(’ to open the parenthesis). Though most keyboards offer you ‘(’, ‘[’ and ‘{,” these are not

scalable; so you can get odd effects if you include them in an expression such as 2@%‘1). If you

use the equivalent math mode delimiters in, for example, two slightly different expressions,
2 2 2

2p ;LQ) and (pr—;q ), the delimiters are scaled to match the expression. This applies when using

a b

c d

Z ] inside delimiters or to create an array {

. . . a
the next two icons, to insert a matrix [
c

The next four icons allow you to add or delete rows or columns to and from matrices and arrays,
in the course of which the delimiters will change size:

a b
c d
e f

Matrices and arrays have the number of containers needed to match the number of rows and
columns you have specified. (I had to put something in the containers in order to illustrate the
matrices and array in the output though the containers were visible on the input screen).

Note that the delimiters create a container in which to hold an expression, matrix or array
and so are best entered before the expression though in some cases you can also highlight an
expression and then select a pair of delimiters. This also means that, if you try to delete a
delimiter, you will delete its contents; so cut the contents, delete (not cut) the delimiter and
paste the contents in the math mode container to get rid of an unwanted delimiter.

The last icon toggles between the basic toolbar and both.

6.3. The advanced toolbar

The advanced toolbar offers a wider range of alternatives such as two smaller styles than in-line
mode, for example: z2—y2=:2, several different types of fraction, such as km/n, and access to
a wide range of mathematical symbols. Some of these, like the fractions, create additional
containers.

Before and after the icons for the alternative styles and alternative fractions are the icons for
alternative spaces and fonts; though you can leave the spacing and fonts for most maths up
to MTEX, for some expressions some intervention may be required. The example given in the
LyX help is that, when entering integrals, LyX accepts [ A(z)dz, and inserts the correct space
between [ and A. However, there should be a small space between (z) and dz and the d in dx
is an operator which should be set upright. A thin space is selected via the spaces icon and
the d is made upright by highlighting it and either using the keyboard shortcut Alt+C R or
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Figure 10: Advanced maths — AMS styles and toolbars

selecting the fonts icon and Roman. This gives: [ A(x)dx. You can make vectors upright bold,
as in v, by highlighting them and using Alt+C R and Alt+C B or selecting the fonts icon and
Roman and then Bold. (You don’t have to repeat this every time you want to enter a vector —
you can copy and paste it once you have made the changes; for a different vector, just change
the character).

Changing fonts in math mode is different from changing them in text mode. In text mode,
the changed font adds an attribute to the text which the user can turn off at any point; in
math mode it creates a container. In both math mode and text mode, you can carry on adding
characters in the same font if you want but in math mode, when you have finished, you don’t
switch off the attribute, you move the cursor to get out of the container.

Typesetting certain maths functions requires the alternation between upright and italic charac-
ters and TEX cannot tell whether a sequence of alphabetic characters like tan is supposed to
be t X a X n or ‘tan’ where it means ‘tangent.” So in an expression like ‘the polar form of the
complex number z = a + bi = (r,0) = r (cosf +isinh),” ‘cos’ and ‘sin’ are both inserted from
the list of functions that appear when you select e,z{;)n and not typed in as separate letters (in

an
This ensures that they are typeset upright unlike all the other characters in the expression.

Figure 10 the advanced toolbar is above the basic toolbar and the function list obscures EfGXp )
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Among the functions supported in this way are ‘det’ as in ‘where A = [ CCL Z ], det A =
det (AT) = ad — be, ‘log’ and ‘In’ as in ‘In (sin™z) = —uln (sinz)’ and ‘lim’ as in

N
/ f(x,y) dA = lim Z f(xi,y:) 0A; where 6A; — 0 for each ¢ and N — oo
S N—o0 -1

A in the ‘det’ example illustrates the next icon, for adding decorations to one or more characters,
for example, to indicate vectors. The decoration creates a second container into which you
can place one or more characters or symbols, for example, Pﬁ, but in order to get out of the
decoration container, you have to make two cursor movements or use Esc.

The remaining icons in the advanced toolbar provide access to the wide range of mathematical
symbols one might need including big operators, such as ), a range of miscellaneous operators,
such as V and R, the Greek characters, such as A\, a multiplicity of arrows, such as &, smaller
operators, such as N, and relationships, such as #. (Though it is possible to cancel characters
in WTEX, this does not always produce a typographically attractive result. So a number of
cancelled characters like # have been created to produce a more pleasing result).

Apart from the dots icon, the remaining icons provide, for the most part, alternatives developed
by the AMS for those who prefer these to the standard symbols. If you are using a lot of
symbols associated with a particular icon, you can add a toolbar for these symbols with View >
Toolbars> Other toolbars.

6.4. The AMS document classes and more

If you are producing a mathematical document, ensure that the AMS and esint packages
are enabled in Document> Settings>Math options; you can add paragraph style modules with
Document > Settings > Modules to a general document style or use the AMS document classes
which incorporate paragraph styles such as Theorem, Corollary, Lemma, Proposition and
Conjecture, all of which have numbered and unnumbered (asterisked) versions. Figure 10
illustrates three of these styles in use (as well as the tabs when more than one document is
loaded). You can also insert numbers after mathematical expressions in display mode and
cross-reference them within the document.

If you intend to use any of the features of the advanced toolbar or the AMS document classes,
it is worth reading the IyyX maths help — even seasoned KTEX users will gain from it.

7. BibTEX and BibBTEX

You can insert references into a LyX or BTEX document by using the Bibliography paragraph
style. That may be enough for you if you only insert a handful of references a year into
relatively short documents. But, if you frequently use references, particularly in an academic
context or within long documents, the benefits of using BIBTEX or BIBATEX appear to increase
exponentially the more you use it. However, while it is theoretically possible to use the
Bibliography paragraph style and BIBTEX or BIBITEX in the same document with the addition
of some IXTEX macros, it is better to choose one or the other for each document you create.
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BIBTEX was written by Orem Patashnik (1988) to work directly with TEX and, like pretty well
everything to do with TEX, it has acquired many extensions and even some different versions
to deal with problems not originally envisaged in the 1980s. Development of BIBTEX has all
but ceased following the development in the first decade of this century by Philipp Lehman of

BBITEX which works with IATEX rather than TEX.

LyX 2.4 has full support for BIBXTEX which can make use of BIBTEX bibliographic databases

— so you do not lose all the work you did collecting references for BIBTEX — but you may find
that you have to load some more IATEX packages in order to use British English bibliographic
styles with BIBIXTEX. If you are writing British English documents, BIBTEX may be fine as you
are less likely to need non-US English characters in your references. If you are writing in almost
any other language, the advantage of using BIBIATEX is that you can create Unicode BIBTEX
bibliographic databases rather having to use all the workarounds which have been developed to
enable people to use non-US English characters in BIBTEX bibliographic databases.

Document > Settings > Bibliography (Figure 11) shows the range of options which LyX 2.4 supports,
the original BIBTEX, the Jurabib and Natbib extensions, BIBIXTEX and the Natbib extension.
Natbib supports variants of the Chicago/Harvard bibliographic styles.? It also allows you to set
a default bibliographic style and to indicate whether you intend to use multiple bibliographies.

This is where you make your choices of BIBIATEX citation style and bibliography style. However,
BIBTEX allows you to make a different bibliography style choice when you add the database
with Insert> List/Contents/References> Bib(La) TeX bibiography.

BIBTEX has two main elements: a bibliographic database and a bibliographic style. As BIBIATEX
can use the bibliographic database, it is worth knowing about it.

7.1. The BibTgX database

The structure of a BIBTEX database, which is possibly unique in allowing records with different
structures to co-exist within the same table, is

ORECORDTYPE{identifier,fieldnamel=contents,fieldname2=contents, ... }

The first part determines whether the record refers to a book, article, chapter in a book, thesis,
etc. The identifier acts both as the index key for BIBTEX and as a human readable identifier
for the user to identify a record in a file; so it needs to be created with care.

There are about twenty potential record types, some of them duplicates, each of which has
a small number of mandatory fields and normally one or more optional fields. You can also
create your own fields if you want to store additional data about a particular reference.

Alphanumeric fields are enclosed in double inverted commas but square brackets can be used
if it is necessary to use double inverted comments within a field. Numeric fields like volume
number can be changed to alphanumeric fields by enclosing the contents in double inverted
commas if, for example, volume numbers are expressed as Roman and not Arabic numerals.

2The name ‘Harvard’ came after an English academic visited Harvard over a century ago and saw people using
the new-fangled Chicago styles and mistakenly thought they had been developed by Harvard academics.
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Figure 11: Bibliographic style selection

The best summary of the available record types and fields is in Tame the BeaST by Nicholas
Markey (2009) available from CTAN.

Figure 12 shows an extract from a BIBTEX file with syntax highlighting; record type is blue,
the identifier green, the field names brown and the alphanumeric fields red. The black fields
are all numeric; in some BIBTEX styles, the normal three letter abbreviations of the month can
substitute for a numerical value in the month field but this does not work with all styles and so
I normally enter the full name of the month within double inverted commas.

Many reference styles abbreviate personal names to initials and make titles lower case. So in
the second record, \relax is added to ‘Revd’ to ensure that it is not abbreviated to ‘R. and
both it and ‘Mad Quakers’ are placed in braces to ensure that they are excluded from normal
processing. The note field is not subject to any processing; so I have had to add the \textit
macro to ensure that the title is printed in italics; this is handled automatically in the book
title and journal fields. In the first record I had to precede ‘&’ in ‘Routledge & Kegan Paul’
with \ and enclose them in braces to ensure that it is not processed as a TEX command (see
Section 7.2.3).
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Figure 12: A BIBTEX database

7.2. Tips for entering data
7.2.1. Authors and editors

Book references may have an author field, an editor field or both. For an @BOOK record, use
either the author or the editor field (not both); for an @ NCOLLECTION record, that is, a reference
to a chapter in a book, there will be the author(s) of the chapter and the editor(s) of the book.

You must use ‘and’ between the names of multiple authors/editors in the author and editor
fields, however unnatural this may look, because BIBTEX uses ‘and’ as the delimiter. Where
appropriate, ‘et al” will be used in the citation (Figure 14) and the names will appear in the
reference with commas between all but the last two, as on page 29. If you want to force ‘et
al’ in a reference, perhaps because you are citing a research paper to which lots of researchers
have contributed, use ‘and others’ in the BIBTEX record.

7.2.2. First von Last

BIBTEX expects names to consist of two or three parts; if the author is an organisation, you
need to put the whole name in braces to prevent BIBTEX breaking it up. Otherwise, BIBTEX
looks for the most sensible way of breaking up a name into first names, a ‘von’ part (for which
you may need to use \relax) and a last name. You can help by entering names as ‘lastname,
first names’ but you don’t need to; BIBTEX will try to make sense of whatever is there. If
you get unexpected results, Nicholas Markey (2009) gives an excellent account of the ways to
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handle different types of name.

7.2.3. Common non-alphabetical characters

Because IXTEX uses certain non-alphabetical characters as part of its syntax, they need to be
distinguished in BIBTEX files.

Character expressed in BIBTEX Character expressed in BIBTEX

# {\#} { ({3

$ {\$} } {\}}

% {(\%} ~ (N~{}}

- AN {3} / {\//3

& {\&} \ {$\setminus $}
A

7.2.4. Accents

Though the default character set for IXITEX is now utf-8, when BIBTEX was created, it was
Latin-1 (or ISO/IEC 8859-1). So you need to use the symbols created for pre utf-8 KTEX in

BIBTEX databases. Scott Pakin maintains a comprehensive list of the symbols available in pre
utf-8 KTREX and their packages which is available from CTAN.

The main Western European accents are expressed in BIBTEX databases which you intend to
use with a BIBTEX bibliography style as follows:

Character expressed in BIBTEX Character expressed in BIBTEX

e acute {\'e} o circumflex {\"o}
e grave {\ e} n tilde {\~n}
¢ cedilla {\c{c}} u umlaut {\"u}

For the rest, and for a huge range of other symbols and icons which you might be interested in
using in your main text, download Scott Pakin’s list of symbols from CTAN.

You do not need to use any of these in a BIBTEX database if you are only ever going to use
BIBIATEX bibliographic styles but you may find that some of the symbols are useful in your
main text.

7.2.5. Inverted commas

With IWTEX having adopted utf8, you can enter opening and closing single (‘...’) and opening
and closing double (“...”) inverted commas in your main text from your keyboard; however,
in BIBTEX, you need to enter opening and closing single inverted commas in the traditional
KTEX way (*..."). To include opening and closing double inverted commas, you need to insert
the TEX code {\textquotedblleft } and {\textquotedblright }.

However, if you want to enter a traditional single quote (') in your main text, you will almost
always find that it is changed to . So, if it is important, as in the table of accents above, to
display a traditional single quote in your main text, you need to insert it as the TEX code
\textquotesingle.
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7.2.6. Hyperlinks and URLs in BibTgX files

You can insert hyperlinks and URLs in BIBTEX files by enabling hyperref support in Docu-
ment > Settings> PDF Properties and using the ITEX macros \href and \url which should be
enclosed in braces within the relevant field. This allows you to create a link to a document on
the web while displaying only the title of the document or including an author’s email address
as a link from their name, for example,

{\href {http://www....}{<title of document>}}
{\href{mailto:<email address>}{<author>}}

Alternatively, the URL macro will display the URL as part of the reference:
{\url {<URL>}}

7.2.7. Empty fields

For the most part, an optional empty field will cause no problems. But some bibliographic
styles will stop reading a record once they encounter an empty optional field. So it is generally
prudent to delete empty optional fields which come before your last filled optional field. Note
also that, where you have a choice of volume or number, you must not include both fields even
if one of them is empty.

7.3. Adding the BibTgX database file

To add a BIBTEX database file to your LyX document, use Insert> List/Contents/Referencesr>
Bib(La)TeX bibiography in an empty standard paragraph where you want the references to
appear in the document. Selecting Add Local in the middle column and, if your BIBTEX file
is in the same folder as your LyX document, it will be there to be selected. Once you have
selected it with Open, it will appear in the Selected: window (Figure 13).

If you are using BIBTEX, you will see the option to select a bibliographic Style. If you are
using BIBETEX, you will not see this option as you can only select this in Document > Settingsr
Bibliography.

If you don’t know which to use with BIBTEX, and prefer numerical citations, choose plainnat;
if you prefer author-year, choose chicago; then OK the dialogue. Both need Natbib enabled as
described in the next section.

The closest equivalent natbib mode BIBATEX style to plainnat is trad-abbrv while the closest
equivalent to chicago is apa6.

7.4. BibTEX styles

As with most things to do with TEX and BKTEX, BIBTEX quickly acquired extensions, particularly
Natbib, created by Patrick Daly (2010), and later Jurabib which allow you to vary the the
citation between, for example, ‘(Daly, 2010),” ‘Daly (2010)’ or just ‘(2010),” to add comments
like ‘for example’ before or page numbers after a citation or, in the case of Jurabib, to use
‘tbidem.
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BibTeX Bibliography

Databases

Found by LaTeX: Selected:

acompat Add Selected Computing
biblatex-examples
book

comment
dtk-bibliography
example-glossaries-acronym Delete
example-glossaries-acronym-desc
example-glossaries-acronyms-lang

Add Local...

Inherit from Master

Up

example-glossaries-brief Down
example-glossaries-childmultipar
example-glossaries-childnoname
example-glossaries-cite

example-glossaries-images Edit...
example-glossaries-long
example-glossaries-longchild

Filter: “v'\l avail. databases | Encoding: | Document Encoding v
Style

chicago ~ |Add Local...
Options

Content: | all cited references ~ Add bibliography to TOC

Rescan ¥ OK @Close | « Apply

Figure 13: Inserting a BIBTEX database

A number of Natbib styles, like plainnat, duplicate an original bibliographic style in the
references but allow the author to choose between leaving Numerical enabled or enabling
Author-year. Others, like chicago, benefit from Author-year being enabled via Documentst>
Settings> Bibliography > Natbib > Author-year so that you can use all the different citation styles
that are associated with author-year referencing. The most recent summary of Natbib is available
from CTAN while the Bibliographic styles catalogue for LyX summarises the bibliographic
styles supported by LyX.

7.5. Inserting citations

Once you have inserted the link to the BIBTEX database, you can begin to insert citations.
Figure 14 shows the dialogue you see after selecting Insert> Citation or the icon that looks like a
bunch of papers.

The upper left window lists the identifiers from the BIBTEX database; if you have a very large
BIBTEX database (700 entries is the maximum recommended size) or you forget the identifier,
you can search on any term in the BIBTEX entry.
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Figure 14: Inserting a citation

butchercopyediting is still highlighted because I have just selected Add and it has appeared
in the upper right window. You can create multiple citations at the same point in a document
by selecting and adding further citations to the upper right window and there are options to
move citations up and down in that window in order to change the order of their citation.

Below these windows, the contents of the highlighted BIBTEX record appear as a CSV record
showing ‘and’ being used as a delimiter and the braces I added to force BIBTEX to capitalise
the ‘C’ in ‘Cambridge’

This display is helpful if you have two similar identifiers and have forgotten which reference you
want to cite. It also helps if you have entered a foreign character not recognised by BIBTEX, as
they often shows up in this window allowing you to alter them before trying to use the reference
and throwing up an error message.

The lower part of the dialogue contains the Natbib extensions which allow you to specify, among
other things, how the citation will appear in the text. You can see that Natbib is using ‘et al’
in the citation because there are more than two authors and that I have chosen the option
to have the entire citation in parentheses with a comma before the year. Below are the Text
before and Text after dialogue boxes (the latter hidden) and two further options for handling
references.

If you have not enabled Natbib or Jurabib in Documents> Settings > Bibliography, the lower part
of this dialogue will be inaccessible — a useful reminder if you have rushed to insert the link to
the database but forgotten to enable one of them.
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7.6. Sectioned and multiple bibliographies

Though IyX does not support sectioned or multiple bibliographies as standard, it does support
the bibtopic package for BIBRTEX and the refsection option for BIBXTEX; so it is possible, by
adding some IXTEX macros, to add these as explained in Help > Additional Features > Bibliography
Multiple Bibliographies.

7.7. The power of BibTEX

You really begin to appreciate the power of BIBTEX when you are dealing with multiple complex
references; apart from the fact that, once you have the correct reference in your database, you
know that it will be correct in every document you produce, where you cite multiple references
by the same author in one year, Natbib will add the ‘a’, ‘b’, ‘¢’ to the year in the citation and
the references and ensure that they are always correctly cited in your document. It even knows
that you use ‘2006a,b’ in an author-year citation when you cite two references from the same
author in the same year at the same place.

If your publisher wants a different style, there are only a few extreme changes of style, like
plain to chicago, where you need to do anything more than opening the dialogue in Figure 13
for BIBTEX or the one in Figure 11 for BIBUWTEX and changing the bibliographic style. BIBTEX
and BIBIATEX will handle everything else.

And finally ...

I have only been able to scratch the surface of the range of options that IyX 2.4 offers from
version control and change tracking to detailed manipulation of the typesetting. There is a
wealth of material in the help documentation which I have never experimented with because,
so far, I haven’t needed to. Maybe you will.

A. TEX and BTEX

The TEX typesetting engine was written in Pascal by Donald Knuth (http://www-cs-staff.
stanford.edu/~uno/) following receipt in 1977 of the proofs for the second edition of volume
2 of The art of computer programming (1981). Whereas the first edition had been set by the
traditional hot type process, the second had been set by phototypesetting and looked awful.

TEX? implements best typesetting practice as set out in the The Chicago manual of style
(University of Chicago Press, 1982). The TEX engine was essentially complete in 1982 but
development continued until 1989. However, passing parameters to TEX required detailed
knowledge of Pascal. So Leslie Lamport, then an employee of SRI International, created a set
of macros which allowed a less sophisticated user to use TEX.

Leslie Lamport placed these macros in the public domain and they were taken up and developed
with such enthusiasm, in particular by the American Mathematical Society (AMS) to typeset

3The name TEX is a representation of the Greek letters T, E and X which start the word from which we get
‘technical;’ so it is pronounced ‘tech’ as in ‘technical’ rather than ‘teks’
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mathematics, that IXTEX forked and, in the early 1990s, there had to be a major re-write to
bring the main forks together. By that time Leslie Lamport had handed over responsibility for
IXTEX to Frank Mittelbach.

KTEX has spawned a large number of packages, all of which are available from CTAN and
some of which conflict as it is impossible for an single person to be familiar with every package.
So people have created distributions which provide the core packages for users, among them,
TeXLive and MiKTeX.
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